Welcome to American Weather
Sign in to follow this  
Followers 0
ROOSTA

GEMPAK AWIPS WRF GRADS-II

9 posts in this topic

Ok guys, gals I write this request for all the hardcore forumites.

About a year ago I downloaded GEMPAK, unpacked, compiled changed profile envoroment variables, make clean. Everything seemed to work and actually had the graphic output working.  

Long story short version- my computer crashed.  

 

Here is the problem. Built new computer and have tried using CENTOS 5, 5.8 just about every OP system that will work with the software. Does anyone know UNIX and would be willing to help with scripting, (especially environment variables) sourcing the profile in a bash terminal. I'm lost and would be an education with many to benefit in a step by step set-up.

 

This probably is more suited for a programmers forum. But what the hey

 

Just a shot in the dark hoping somebody with the knowledge and patience willing to share.

 

-Don

Share this post


Link to post
Share on other sites

I'll help. Installed many a GEMPAK package in UNIX/Linux. Have about 60 shell scripts that make GEMPAK images. From your post I can't tell what you need.

Share this post


Link to post
Share on other sites

Thank-you for the responce.

Starting from ground up.

Presently running Ubantu 12.04 LTS, AMD 8150 processor X8, 32 Gb of mem, 2TB of storage space. Some much for the hardware.

My biggest problem is no matter how many times I try to add the "path" to get the program to run.

The direction are vague (maybe just me) Unidata has the following

 

  

Sourcing Environmental Variables

 

csh/tcsh

source the full path of Gemenviron in your .cshrc

source /home/gempak/NAWIPS/Gemenviron

 

bash

add the following to .profile

. /home/gempak/NAWIPS/Gemenviron.profile

 

Logged in as Admin, source the $PATH  everything appears good. Close the terminal and reopen echo $PATH and its there. The enviroment variables are tripping me up. This is when you should be able to "makefile" and the whole program should compile. All the libraries are there, the program is intact. Compiling using makefile does not work because of the intitial script into the path.

 

UNIX 101 is basic and very complex in many ways. I'm stumped and frustrated to no end. I see there is an RPM version which will be tried

Thank-you again.

Share this post


Link to post
Share on other sites

the unidata instructions you show have nothing to do with building gempak. They have to do with running it. are you having trouble compiling gempak?

Share this post


Link to post
Share on other sites

You are correct. The program will not build. I'm sorry for the confusion. My knowledge of Unix is limited as you can tell. Adding the path correctly is the problem. 

Share this post


Link to post
Share on other sites

A longtime ago I had a vision of runnung GEMPAK using as homegrown graphics. Recently a Youtube video was uploaded with a step-by-step install which actually got the progran to run. The tutorial on Unidata is not very good and backward in compilation.

 

At the rate, this attempt hopefully wil not take as long a getting the program to run.

 

I know very little UNIX and even less of scripting. There are no directions on:

 

Download of grib files and decode to usable grid data.????

Share this post


Link to post
Share on other sites

I managed to get GemPAK compiled on Ubuntu a lot easier than CentOS (some way, pretty ridiculous).  This guy right here has written some free scripts to help you on your way for later:

 

http://tempestchasing.com/gempak/

 

The biggest issue is without a NOAAPORT, you're going to be having to write custom scripts to download model data (unidata offers a data server with files already into GEM files btw) for all over different web sources.

 

Here are a good many grib2 models.  Somewhere on the server are the files already converted to gem also: http://thredds.ucar.edu/thredds/catalog.html

 

Overall, there are people who are willing to give you access to a NOAAPORT, just have to find the right people.  I'ts not cheap to set your own up outside or anything like that, but you can go that route.  Generally NOAAPORTS have everything you could ever want within reason already converted to GEM so then you just have to set up a script to download the GEM files (alrdy converted) from the NOAAPORT and then generate images etc.

 

I personally despise GemPAK, and have learned GRADS does about anything you could ever want.  Plus it's much less buggy and user friendly scripting wise.  In fact, Grads is used for many NOAA graphics.. even used for wxbell etc.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.